MetaTrader 4和Mq4在Linux Ubuntu上使用Wine

在过去的几年中,随着移动计算带来的深刻变化,一个事实在十年的大部分时间里一直保持相对稳定。基于Linux的计算机,特别是Linux台式机,仍然仅占全球所有计算机的2%。如果您是Linux的忠实粉丝,那么您真的必须接受您的经纪人和/或其他软件开发人员在支持Metatrader 4(简称Mt4)时几乎处于孤岛。 MT4。尽管成为Linux用户,但令人高兴的是,其他Linux用户以及整个Linux用户社区在互相帮助方面都很棒。因此,尽管您不会从经纪人或Mt4获得支持,但Linux上其他MT4用户可能会很乐意为您提供帮助。

通常,这是必要的。如果您的特定平台没有技术支持,则与Linux社区共享知识来解决问题是您的最大利益。通过帮助他人,您还可以帮助自己和整个社区,从而将错误报告给开发人员,并对软件进行改进。 Linux毕竟是免费的,并且是许多其他开源软件的灵感,我们今天都喜欢它,其中最著名的是Google的Android OS和WordPress。

除了可以从经纪人和开发人员那里获得最小的直接支持外,在Linux上使用Metatrader 4可能还会遇到其他挑战。最大的挑战是,不能保证MT 4会在100%的时间内工作。我已经在其他版本的Linux上使用过Mt 4。 Puppy Linux和Ubuntu Linux表现出色。许多其他版本的Linux惨遭失败。我个人只是选择尝试各种Linux版本,直到找到可行的版本。

要运行像Metatrader 4这样的本地Windows应用程序,最经济有效的方法是使用一个名为Wine的开源应用程序。现在,尽管我知道有可以使用的商业替代方案,但这超出了本文的范围。而且,Wine是一种Windows模拟器,它随时可用,并且几乎包含在所有主要的Linux版本中。几个月前,在更新到Ubuntu 12.04版本之后,我尝试使用最新版本的Wine(版本1.4)运行Metatrader。这是一个非常简单的过程,几乎不需要安装或修改

  1. 确保Wine安装在Linux机器上。确保在Linux终端上键入wine –version。
  2. 在Linux中打开文件管理器,然后转到Windows文件所在的驱动器以及Metatrader文件夹所在的驱动器。通常:c:Program FilesMetatrader否则为c:Program Files您的经纪人名称。 FXDD,Alpari
  3. 指向并右键单击名为“ terminal.exe”的文件
  4. 选择“用Wine Windows程序加载器打开”

通常,Metatrader打开之前会有一个延迟。它不会像在Windows计算机上那样立即打开。您必须记住,有很多资源需要进行仿真,像Metatrader这样的轻量级程序在其本机环境之外变得更加繁重。

如果Metatrader在您的Linux机器中打开,那么您很幸运。您已经取得了许多尚未取得的成就。但是,如果您在此过程中不走运,还可以尝试其他一些方法。

首先检查您使用的Wine版本。在Linux上打开终端并输入命令: 葡萄酒-版本

我的展示了Wine版本1.4在以前的Wine版本中,我无法使Metatrader正常工作。当Wine 1.3对我不起作用时。我搜索了Wine仓库,卸载了Wine 1.3,然后安装了Wine版本1.2。它运行正常,降级不会影响Metatrader 4的功能,并且我能够运行其他Windows应用程序,例如Quicken和Options交易软件。

检查WineHQ网站。用户将就有效和无效的问题提供反馈

您几乎必须具有这样的思想,即在Linux上运行诸如Metatrader之类的应用程序尚处于Beta阶段。有时会发生故障,它带来的好处是不必仅使用Windows运行Metatrader。我在Linux计算机上启用Metatrader已有几天,没有崩溃或停止。我可以监视交易,更新和修改图表并运行专家顾问。因此,我可以告诉您,过去几年有了很大的改进。 7-8年前,当我第一次开始使用Metatrader时,在Linux上使用它只是一个不可能的梦想。着眼于移动计算和跨平台计算,我希望开发人员转向基于Web的Metatrader端口,这样Linux用户就不必希望并希望使用Metatrader功能之类的出色应用程序。

原创文章,作者:WPJIAN,如若转载,请注明出处:https://wpjian.com/tips/2020010429616.html