如何在Linux上安装Metatrader 4

在Linux平台上运行Metatrader 4引起了很多兴趣,但是直到Metaquotes开发出本机Linux版本之前,唯一要做的就是在WINE仿真下运行它。

接下来是在Linux中安装MT4的分步指南。我可以使用出色的Ubuntu发行版来完成此任务,尽管您可以轻松地对其进行调整。例如,这也适用于Gentoo。

反正…

1)如果尚未安装WINE,请安装。

sudo apt-get install wine

安装WINE之后,您需要对其进行配置。这很容易。以普通用户身份(不是超级用户!)运行 winecfg 从终端,它应该自行设置。如果您想进行更多配置或调整,请查看选项卡,但目前我建议将其保留为默认设置。

2)从有效的Windows安装中,将所有字体复制到wine安装中。它还假设您告诉Ubuntu将Windows分区挂载在/ windows中。

cp / Windows / WINDOWS /字体/ *〜/ .wine / drive_c / Windows /字体/

3)从有效的Windows安装中复制2个所需的DLL文件。

cp / Windows / WINDOWS / system32 / mfc4 *〜/ .wine / drive_c / Windows / system32 /

4)从您喜欢的经纪人处下载mt4setup,或从rebatefx.com上找到经纪人建议之一。

5)安装MT4。

酒mt4setup.exe

6)您现在应该在桌面上有一个图标,并且在Linux下可以正常安装MT4!双击以启动。如果第一次运行需要一段时间,请不要惊慌。

但是,在撰写本文时存在一些小问题。在仿真为另一个平台编写的软件时,这是可以预期的。这些问题可能包括(并非所有人都遇到),由于无效的参数错误而无法下达限价单或止损订单,无法更改趋势线和指标线的宽度以及某些情况在没有安装Internet Explorer 6或更好版本的情况下,Meta编辑器将拒绝运行。虽然不能保证可以解决此问题,但对于那些坚持要求您使用它或进行网页开发的网页,安装Internet Explorer很有用。

要安装ie6,可以使用出色的ies4linux软件包。以下命令应在Linux机器上安装ie6。

须藤apt-get install cabextract
get http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
焦油xzvf ies4linux-latest.tar.gz
cd ies4linux- *
./ies4linux

所以你有它。 Metatrader 4在Linux中工作。好吧,主要是;)

它不是完美的,但是如果您以市场价格输入价格,这是一个可行的解决方案。当意外的病毒检查或令人讨厌的Windows更新弹出窗口夺走了交易终端的焦点时,这无疑对新闻交易很有好处,这会浪费您宝贵的时间,这可能意味着赚很多钱或少赚一点钱。更糟糕的是,您的图表设置甚至整个帐户都因病毒或键盘记录器攻击而丢失。 :o

祝你好运,交易愉快!

Total
0
Shares
相关文章