使用技巧

WordPress 5.5及以后版本的主要jQuery更改

jQuery 5.5以及其他主要jQuery更改的主要途径-WordPress 5.5及以后版本的主要jQuery更改

随着JavaScript和更新的,更精简的框架取得的所有进步,有时很容易忘记WordPress仍然依赖于老化的jQuery库。 官方WordPress目录中的数千个插件和主题也是如此。

对于某些人来说,这可能就像一段回到2000年代中期的旅程,那时JavaScript非常像狂野西部。 jQuery解决了编程语言的许多问题,这些问题未能满足开发人员需要完成的工作。

亚伦·乔宾(Aaron Jorbin)四年前创建的一张门票 将WordPress移至最新的3.x分支 的jQuery终于实现了。 但是,WordPress开发团队将需要分阶段进行此过渡,尤其是在等待了这么长时间之后。

WordPress在保持jQuery更新方面落后。 对于通常暗示用户需要运行最新和最佳版本的平台,奇怪的是WordPress本身并未对它依赖的第三方代码进行相同的操作。 WordPress当前捆绑了jQuery版本1.12.4,这是2016年发布的库的版本。它也是支持Internet Explorer 6、7和8的版本。

WordPress首席开发人员Andrew Ozz在谈到平台落后的原因时说:“主要是因为最近几年的重点已转移到其他/更现代的JavaScript库上。” “对核心做出贡献的JavaScript开发人员数量有限,并且需求量很高。”

从长远来看,他说未来的选择可能是将WordPress管理员完全移至本机(原始)JavaScript,这是他在发布公告的评论中分享的一种观点。 更新jQuery的版本 与WordPress捆绑在一起。 他说:“这将是巨大的,同时也需要很大的努力。”

太多的主题和插件依赖于此版本的jQuery来加快移动速度。 虽然插件可以选择用最新版本覆盖WordPress核心捆绑版本的jQuery,但主题没有这种选择。 官方主题目录准则要求主题必须利用核心捆绑的脚本(包括jQuery)。 这样做有一个很好的理由:在大多数情况下,它确保与核心和第三方插件兼容。

但是,现在该继续前进了。

开发人员和用户需要知道什么jQuery 5.5和Beyond-1的主要jQuery更改方式WordPress 5.5及以后版本的主要jQuery更改

WordPress有一个分三个阶段的计划来更新jQuery。 核心团队要求主题和插件开发人员开始使用 测试jQuery更新 插入。 这将帮助他们在整个过渡期内使代码保持最新。

此过程的第一步是从WordPress 5.5中删除jQuery Migrate 1.4.1脚本, 今天早些时候发布。 此版本的jQuery Migrate使较旧的代码兼容,并帮助开发人员迁移到jQuery 1.9+。

此举无疑会破坏一些插件和主题。 核心团队已经 启用jQuery迁移助手 插件可供最终用户使用。 “它打算在更新到5.5后遇到与jQuery有关的问题的站点上在生产环境中运行,” Ozz说。 “它可以通过重新启用jQuery Migrate并向网站管理员显示有关使用过时/过时的jQuery函数的警告来工作。”

长期目标是使开发人员更新其扩展。 同时,此插件应可缓解一些问题。

奥兹说,开发人员现在最大的需要做的就是确保他们正在针对WordPress 5.5测试其扩展。 他继续说道:“理想情况下,应更加注意所有基于jQuery的旧脚本,并确认它们仍能按预期运行。” “在几乎所有情况下,修复都是微不足道的。”

超越WordPress 5.5,一切将初具规模。 暂定的计划是将最新版本的jQuery更新并添加最新版本的jQuery Migrate作为WordPress 5.6版本的一部分。

“同样,Migrate将被用来帮助更新基于jQuery的脚本,并在插件和主题得到更新时作为向后兼容性的“修复”,” Ozz说。 “ WordPress 5.6中的Migrate版本将有所不同,因为它对应于最新的jQuery版本。 它的作用与第一次添加时相同,但现在将帮助核心,插件和主题从jQuery 1.12.4更新到3.5.1(或更高版本)。”

该过程的第三步是再次从WordPress中删除jQuery Migrate。 此更改是针对WordPress 5.7的临时计划,该版本将在2021年之前发布。最终目标是消除对Migrate的依赖,并将最新版本的jQuery运到某天(也许是很远的将来),可能不再需要与WordPress捆绑在一起。

“遵循jQuery团队的最佳实践和建议,Migrate应该用作帮助工具,而不是永久的向后兼容解决方案,” Ozz说。 “理想情况下,WordPress将能够做到这一点。”

像这样:

喜欢加载中……

资源