使用技巧

启用jQuery Migrate Helper插件可通过10K有效安装

enable-jquery-migrate-helper-plugin-passes-10k-active-installs启用jQuery Migrate Helper插件通过10K主动安装

自WordPress 5.5发布以来仅一周, 启用jQuery迁移助手 用户正在寻找可修复损坏站点的修补程序,因此该插件已通过10,000次有效安装。 该插件是由WordPress核心团队开发的,目的是缓解用户在更新到5.5后可能遇到的jQuery相关问题。 WordPress删除了jQuery Migrate 1.4.1,但是现在许多主题和插件都已损坏,因为它们使用了依赖于脚本的过时/过时的jQuery函数。

官方支持论坛被淹没了 损坏站点的报告 在更新到5.5之后,由于大多数不遵循核心开发的用户都不知道jQuery Migrate已被弃用。 因为它与jQuery有关,所以许多站点都有非常明显的问题或功能受损,从而阻止用户执行诸如查看和编辑内容之类的操作。 那些仍在使用经典编辑器的人特别 5.5更新遭受的打击最大,因为挂接到旧编辑器的旧插件更有可能使用已弃用的jQuery函数。

Enable jQuery Migrate Helper插件已获得34条五星级评价,可立即修复大多数用户的问题:

“更新到5.5后,我的英雄滑块图像消失了,此插件立即解决了该问题。”

“在更新到WordPress 5.5之后,尽管所有插件和主题都进行了更新,但我编辑帖子页面和其他几件事最终都中断了。 这个插件解决了我的问题!”

“作为报纸,看不到我们帖子的内容是很重要的。 这样就解决了。 谢谢。”

该插件使用户有时间找出导致这些问题的主题或插件,并要求这些扩展的作者对其进行更新以与最新版本的WordPress兼容。

一位用户David Halchester报告了一个 消失的导航菜单 在发现Enable jQuery Migrate Helper插件之前,请访问支持论坛。

“ Voila,” Halchester在他的讲话中说 评论。 “它像魔术一样工作。 我漂亮的自定义页面再次正常工作。 话虽如此-如果WP不想失去客户,则需要确保其更新与旧站点兼容。

“感谢创建此插件的人员。 我只是为自己节省了约300美元或更多的费用,以便有人“修复”它。”

他明确指出该插件可以节省用户的钱,否则这些钱可能会交给开发人员来解决。 对于那些发现该插件为修复程序的人来说,这只会使他们花费时间和沮丧感,无法从托管公司或支持论坛的志愿者那里寻求帮助。 其他可能不太坚持的人则可能需要为专业故障排除付费。

贾斯汀·塔德洛克(Justin Tadlock)发表了 发布 上周概述了WordPress将jQuery更新到最新版本的三阶段计划。 该计划概述了如何在WordPress 5.6中添加新版本的jQuery Migrate,以帮助用户从jQuery 1.12.4更新到3.5.1(或更高版本)。 暂定的计划是在WordPress 5.7中再次删除该脚本,预计在2021年。

同时,Enable jQuery Migrate Helper插件用作临时创可贴。 展望主要核心版本的选择加入自动更新的前景(有望在WordPress 5.6中发布),考虑到这些重大变化在更新jQuery的道路上的影响范围非常重要,特别是对于那些与经典编辑器插件一起使用。

像这样:

喜欢加载中……

资源