Elementor 修补关键安全漏洞的基本插件

Elementor 的基本插件, 一个拥有超过一百万次活跃安装的流行插件, 修补了一个关键漏洞 这将允许本地文件包含攻击。

该漏洞由安全研究员 Wai Yan Myo Thet 发现,并于 2022 年 1 月 25 日向 Patchstack 报告。Patchstack 客户在同一天收到了虚拟补丁。 该插件的开发人员 WPDeveloper 已经知道该问题,他们在最终在 5.0.5 版本中修复之前发布了两个不足的补丁。

Patchstack 发布了漏洞摘要,并解释了使用该插件的 WordPress 网站如何受到攻击:

此漏洞允许任何用户,无论其身份验证或授权状态如何,都可以执行本地文件包含攻击。 此攻击可用于在网站的文件系统中包含本地文件,例如 /etc/passwd。 这也可用于通过包含通常无法执行的恶意 PHP 代码文件来执行 RCE。

请务必注意,该漏洞主要影响使用动态库和产品库小部件的用户。

该插件的变更日志使更新看起来更像是一种增强而不是严重的安全问题,因此用户可能没有完全意识到他们需要更新:

5.0.5 – 28/01/2022
改进:增强安全性以防止通过 ajax 请求从远程服务器包含不需要的文件
5.0.4 – 27/01/2022
改进:用于安全增强的清理模板文件路径
新增:支持 WordPress 5.9 的新功能查询
已修复:未触发 Elementor 弹出窗口
一些小错误修复和改进

低于 5.0.5 的所有版本都被认为是易受攻击的。 WordPress.org 统计数据不会根据次要版本细分活跃安装,但大约 54% 的插件用户运行的版本早于 5.0。

Essential-addons-for-elementor-patches-critical-security-vulnerability Elementor Patches 关键安全漏洞的基本插件

虽然这看起来可能有超过 50 万用户仍然容易受到攻击,但他们还需要使用相关的特定小部件。 如果您不确定是否组合使用这些小部件,最好还是尽快简单地更新。

来源

Total
0
Shares
相关文章